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Abstract-Simulation based approach to teach the
Power Electronic course is proposed in this paper. The
simulation tool is oriented towards Electrical and
Electronics Engineering (EEE) students at the
undergraduate level, enrolled in courses such as
Power Electronics, Power Semiconductor drives or
the like. The proposed teaching methodology is
demonstrated by simulation example of a realistic
converter system. The paper discusses the MATLAB/
SIMULINK tool and the implementation of
simulation for enhancing student learning ability of
complex power electronic systems.
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1. Introduction

Simulation software is based on the process of
modeling a real phenomenon with a set of
mathematical formulas. It is, essentially, a program
that allows the user to observe an operation through
simulation without actually performing that
operation. Simulation software is developed to model
and design equipment so that the final product will be
as close to design as possible with no expense in
process modification. Simulation tool with real-time
response is often used in designing, which has gained
researchers interest to develop industry specific
application equipment. Simulation Tools are also
getting recommended to learn many engineering
courses for the students to better understanding of the
content. The computer simulation has become a great
teaching aid or instructional tool for an introductory-
level power electronics course has increased students'
abilities to comprehend the behavior of several power
electronics circuits, giving valuable training
experience to achieve the learning outcome [1].

Many simulation software packages provide a
user-friendly environment that allows the
undergraduate students in electrical engineering to
simulate the power system behavior, power
electronics and drives applications, electronic
circuits, feedback control systems etc. In theory, any
phenomena that can be reduced to mathematical data
and equations can be simulated on a computer.
Simulation can be difficult because most natural
phenomena are subject to an almost infinite number of
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influences [2]. A PC-based computer program, which
runs under the Windows environment, has been
developed at Purdue University Calumet [3]. A block-
oriented digital simulation package is proposed to aid
instruction and research in control of electric drives,
power systems, and power electronic circuits. The
software tool consists of several pre-defined blocks
stored in a library; these blocks can be called from the
library and interconnected as required, based on the
mathematical model of the system to be simulated [4].

Complex circuit dynamics and typical concepts are
involved in Electrical Engineering subjects. Hence it
is difficult to teach the course and making the under
graduate students to understand in the class room
itself. A new software tool for learning the dynamic
behavior of power electronics circuits is developed for
undergraduate students. This tool incorporates the
merits of two well-known software packages, namely,
the realistic time-domain simulation of PSpice and the
parametric identification process of MATLAB [5].
Power Electronics is a professional course with a
strong theoretical and practical base. The objectives
of'this course are: grasping the topology of a variety of
power electronic circuits; the operating principles;
control methods; design calculations and practical
skills; and to be familiar with the scope of applications
for the various power electronic devices, and other
technical and economic matters. Presented an
overview of the development of e-learning materials
in allied field of power electronics and shown some
hints to optimized design from view of purpose of its
utilization [6].

In order to unify the power electronic circuit
analysis a building block is identified in commonly
used power converter topologies in the first course in
power electronics. The use of space vectors is
introduced on a physical basis to describe operation of
ac machines in steady state in the first course of
electric drives, thereby teaching students what they
need to learn, making these courses appealing, and
providing a seamless continuity to advanced courses
[7]. E-learning platform possesses the advantages of
hardware flexibility, friendly user interface, provision
for distance waveform measurements, and removal of
laboratory time and space constraints [§].

This paper proposes the simulink environment to
learn the Power Electronics course more easily. The
teacher can demonstrate visually the dynamic system
behavior by changing the input parameters. This
improves the quality of teaching by making the

abstract concrete, the boring interesting and
stimulates students' interest.

' .o W & .. el A
Bl L8t Dnw; Peale Deop Wedem iip
DJ 4R090 $YF O CllsocdBMTLocme ML -@e

Sotcts 2 Wowlo A2 B Aheishen

Mebsgace. Cemmun Windzw -m2
o |k B | <) e o MATLABT Wetchths e, s (o, v Gling St

SR i I b, cor1i5, are e cupznsranie
o
D@ = bhwemm -3
Ly Semik_Seunt esu o | bes ety || B0
- erin
Commying cerira L
e
o
B o w [H o

W St iy Boman

sy ) s

Fig. 1. MATLAB/ SIMULINK Window
2. Model Based Learning

Model-Based Design is a process that enables
faster, more cost-effective development of dynamic
systems, including control systems, signal processing,
and communications systems. In Model-Based
Design, a system model is at the center of the
development process, from requirements
development, through design, implementation, and
testing. The model is an executable specification that
you continually refine throughout the development
process. The fig.1 shows the window of the
MATLAB/SIMULINK.

After model development, simulation shows
whether the model works correctly. When software
and hardware implementation requirements are
included, such as fixed-point and timing behavior, you
can automatically generate code for embedded
deployment and create test benches for system
verification, saving time and avoiding the
introduction of manually coded errors.

Model-Based Design improves efficiency by:

0 Using a common design environment across
project teams

0 Linking designs directly to requirements

0 Integrating testing with design to continuously
identify and correct errors
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n

Refining algorithms through multi-domain
simulation

n

Automatically generating embedded software
code

0 Developing and reusing test suites
0 Automatically generating documentation

0 Reusing designs to deploy systems across multiple
processors and hardware targets.

There are six steps in modeling any system:
1. Defining the System
2. Identifying System Components
3. Modeling the System with Equations
4. Building the Simulink Block Diagram
5. Running the Simulation
6. Validating the Simulation Results
3. Simulation Examples
A. Openthe Simulink Library Browser

Run MATLAB before opening the Simulink
Library Browser. Then open the Simulink Library
Browser from the MATLAB Tool strip by clicking the
Simulink Library button (). If not already loaded
Simulink, a short delay occurs while it loads. The
Library Browser opens. To keep the Library Browser
above all other windows on desktop, in the Library

Browser, select View > Stay on Top.

B. Create a new Simulink model from Simulink
Library

From the Simulink Library Browser menu, select
File> New> Model. An empty model opens in the
Simulink Editor. In the Simulink Editor, select File >
Save. In the Save As dialog box, enter a name for your
model, and then click Save. Simulink saves your
model.

C. Single-phase dual converter

The single phase full converters with inductive
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loads allow only a two quadrant operation. If two of
these full converters are connected back to back, both
the output voltage and the load current flow can be
reversed. The system provides a four - quadrant
operation and is called a dual converter. Dual
converters are normally used in high power variable
speed drives. Because the instantaneous output
voltages of the two converters are out of phase, there
can be an instantaneous voltage difference and this
can result in circulating current between the two
converters.

IR

i

Fig. 2. Simulink diagram of dual converter fed DC motor
drive

The fig.2 shows the Simulink diagram of dual
converter fed DC motor drive. The results of dual
converter fed dc motor drive; output voltage is shown
in fig.3, Speed-torque characteristics in fig.4.

Fig. 3. Output voltage across Rectifier

Fig. 4. Simulation results of speed, armature current, field
current & torque
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4. Results And Discussion platform has good rating compared to the previous

teaching method as shownin fig.5.

The table II gives course end survey for the PE.
This survey is done in order to perform a qualitative
evaluation of the delivery methodology adopted to
make the students comfortable, consisting of nine
questions which try to elicit their anonymous opinions
on the effectiveness of its various features, on a five-
point scale ranging from 1 (No Comment) to 5
(Excellent). According to the results, the proposed
platform has good rating compared to the previous
teaching methodology in power electronics and power
semiconductor drives course in Shri Vishnu
Engineering College for Women (SVECW). By using
the ST based learning the student results has
improved. Students can also develop the
programming skills by generating the switching
pulses for power semiconductor devices using M-File
instead of using pulse generator directly; this helps the
students to get the placement in software companies
as well. One of the primary advantages of ST is that
they are able to provide students with practical
feedback when designing real world systems. This
allows the students to determine the correctness and
efficiency of a design before the system is actually
constructed. Consequently, the user may explore the
merits of alternative designs without actually
physically building the systems. By investigating the
effects of specific design decisions during the design
phase rather than the construction phase, the overall
cost of building the system diminishes significantly.
Another benefit of ST is that they permit students to
study a problem at several different levels of
abstraction. By approaching a system at a higher level
of abstraction, the student is better able to understand
the behaviors and interactions of all the high level
components within the system and is therefore better
equipped to counteract the complexity of the overall
system. This complexity may simply overwhelm the
student if the problem had been approached from a
lower level. As the student better understands the
operation of the higher level components through the
use of the simulator, the lower level components may
then be designed and subsequently simulated for
verification and performance evaluation as the
students are using the simulation tools and learning
the subjects they can have the meaningful
understanding of the concepts and they can
understand the system behavior. Based on the above
discussion, we in SVECW adopted the Simulation
based learning and we achieved a good result. The
evaluation of software tool used for PE is shown in
figure 7.According to the results, the proposed

Table 1. Questionnaire for evaluation of the
simulation based learning

QUESTIONAIRE

1 Has the course achieved its
Course objectives?

2 Whether the faculty has
helped in acquiring the course | [J| [0 | O O [J
objectives?

3 Whether the faculty has given
real time application of the O o ofop o
subject?

4 Can you design simple power
electronic converter circuits oy o|ofol o
using simulation tool?

Can you study the

5 characteristics of a Power

Semiconductor Device using
simulation Tool?

6 Are you able to design
various inverter circuits?

7 Have you gained knowledge
about PWM technique?

8 Are you satisfied with the YES [ONO
course outcomes met through
this subject?

If your answer is No, please
9 indicate your preferences:
OYES [ONO
More inputs, additional
contents, real life examples

Evaluation of Simulation Based
learning before and after ST Usage

M Before
using ST

S = N W e oD

12 3 456 7 89

Fig. 5. Evaluation of Simulation Based Learning before
and after usage of simulation Tools
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5. Conclusion

In this paper the effectiveness of teaching by using
MATLAB/ Simulink simulation software tool is
explained by modeling and simulating the Dual
Converter Fed Four Quadrant DC Motor Drive as an
example in teaching one of the power electronic
converter circuits. By introducing simulation tools
based learning in the classroom environment the
students can gain more practical knowledge and no
real hardware environment and resources are
required. This makes the students to feel that they are
working in real time environment and this
methodology will increase the confident level of the
student in that course. Survey results also show the
enhanced student interest in learning the concepts
using simulation software rather than chalk and board
methodology.
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